You can’t download Outlook Express 4.5

Update: Since I wrote this entry and actually clicked on the link, I am disappointed to find out it leads to a Mactopia page where you CAN’T download the promised Outlook and IE files. However, Outlook Express 5 is still available. In related news, I managed to find an Office 98 CD, and I think it has OE 4.5 on it, although I’ll have to check.

I did a search, and I can’t believe it. You can download Outlook Express 4.5 for Macintosh (and get IE 4.5 with it, though IE 5 works in 7.6.1 and is way, way stable.)

I didn’t bring the Powerbook with me today, but I’ll have to try this as soon as possible. There are a ton of Web pages out there on how to configure OE 4.5, and from the looks of it, you CAN set up multiple POP accounts.

If you’re running System 8.1 to 9.x, there’s also Outlook Express 5. It almost … almost … makes me want to upgrade.

If I could get the Claris e-mailer to work, I wouldn’t bother, but it doesn’t work.